PHP is one of the most commonly used open-source programming languages. It’s quite popular since it is free software, which you can use to create interactive websites like community websites, online shops or online teaching websites rather than static HTML-based sites. A PHP module must be installed on the server where a PHP-driven website is hosted so that its PHP code can be ‘deciphered’. Because there aren’t any license fees for this type of module and the language itself provides endless options for the apps that you create, there are 100s of millions of PHP websites. Additionally, there’re numerous PHP scripts, which you can use for your websites without needing to possess any coding knowledge. Considering the fact that there’re a couple of versions of PHP, you have to verify if the exact same version that you used whilst creating your website is present on the server too.

PHP 4 and PHP 5 Support in Web Hosting

If you purchase a web hosting plan from us, you’ll never need to speculate as to whether or not your sites are compatible with the hosting platform, since several versions of PHP are supported on our servers for your convenience. The Hepsia hosting Control Panel will permit you to choose PHP 5.5, 5.4, 5.3, 5.2 or 4 with only one mouse click and in case you need to change the current version, the new settings will be applied momentarily. In this way, many years of work on sites created with an older version of PHP won’t go down the tubes. Our hosting platform will even permit you to use a different PHP version for each domain hosted in your account, so you can run newer and older scripts at the same time. Most hosting companies on the marketplace support one, sometimes two PHP versions. In contrast with them, we consider that you should be the one to select the version that your very own websites will be using.

PHP 4 and PHP 5 Support in Semi-dedicated Hosting

If you’ve got a website built with a previous PHP version and you have devoted time and effort to developing it, filling safety holes and appending web page content, you’ll need to find a hosting service that can support it, since the great majority of web hosting vendors these days offer support only for the most recently released version of PHP and drop the earlier versions. We, on the other hand, have decided to allow you to choose the version that your very own sites need. Our Linux semi-dedicated hosting support PHP 4 and multiple versions of PHP 5, which means that you’ll be able to run both newer and older scripts without forfeiting any manual settings or wasting time and energy striving to make your sites compatible with the hosting platform. You can change the current version from the Hepsia hosting Control Panel and such an update will affect the entire semi-dedicated server account, but you’ll also have the ability to pick a different version of PHP for each individual website hosted in your account by means of an .htaccess configuration file.